Numeric Errors Affecting libxrender package, versions <1:0.9.6-2ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.88% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBXRENDER-286040
  • published15 Jun 2013
  • disclosed15 Jun 2013

Introduced: 15 Jun 2013

CVE-2013-1987  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libxrender to version 1:0.9.6-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxrender package and not the libxrender package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Multiple integer overflows in X.org libXrender 0.9.7 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XRenderQueryFilters, (2) XRenderQueryFormats, and (3) XRenderQueryPictIndexValues functions.

CVSS Base Scores

version 3.1