Directory Traversal Affecting libzip-ruby package, versions <0.9.4-1+deb7u1build0.12.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.44% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIBZIPRUBY-262207
  • published27 Feb 2017
  • disclosed27 Feb 2017

Introduced: 27 Feb 2017

CVE-2017-5946  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 libzip-ruby to version 0.9.4-1+deb7u1build0.12.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzip-ruby package and not the libzip-ruby package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses "../" pathname substrings to write arbitrary files to the filesystem.

CVSS Base Scores

version 3.1