Link Following Affecting lightdm package, versions <1.0.6-0ubuntu3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.3% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LIGHTDM-368044
  • published17 Feb 2012
  • disclosed17 Feb 2012

Introduced: 17 Feb 2012

CVE-2011-4105  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 lightdm to version 1.0.6-0ubuntu3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lightdm package and not the lightdm package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

LightDM before 1.0.6 allows local users to change ownership of arbitrary files via a symlink attack on ~/.Xauthority.

CVSS Base Scores

version 3.1