Cryptographic Issues Affecting lynx-cur package, versions <2.8.8dev.9-2ubuntu0.12.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.81% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-LYNXCUR-266872
  • published4 Nov 2012
  • disclosed4 Nov 2012

Introduced: 4 Nov 2012

CVE-2012-5821  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 lynx-cur to version 2.8.8dev.9-2ubuntu0.12.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lynx-cur package and not the lynx-cur package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Lynx does not verify that the server's certificate is signed by a trusted certification authority, which allows man-in-the-middle attackers to spoof SSL servers via a crafted certificate, related to improper use of a certain GnuTLS function.

CVSS Base Scores

version 3.1