Cryptographic Issues Affecting maas package, versions <1.2+bzr1373+dfsg-0ubuntu1~12.04.4


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.94% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-MAAS-300557
  • published23 Nov 2013
  • disclosed23 Nov 2013

Introduced: 23 Nov 2013

CVE-2013-1058  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 maas to version 1.2+bzr1373+dfsg-0ubuntu1~12.04.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream maas package and not the maas package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

maas-import-pxe-files in MAAS before 13.10 does not verify the integrity of downloaded files, which allows remote attackers to modify these files via a man-in-the-middle (MITM) attack.

CVSS Base Scores

version 3.1