Access Restriction Bypass Affecting moin package, versions <1.9.3-1ubuntu2.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.11% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-MOIN-326578
  • published10 Sept 2012
  • disclosed10 Sept 2012

Introduced: 10 Sep 2012

CVE-2012-4404  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 moin to version 1.9.3-1ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream moin package and not the moin package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

security/init.py in MoinMoin 1.9 through 1.9.4 does not properly handle group names that contain virtual group names such as "All," "Known," or "Trusted," which allows remote authenticated users with virtual group membership to be treated as a member of the group.

CVSS Base Scores

version 3.1