Cross-site Scripting (XSS) Affecting moin package, versions <1.9.3-1ubuntu2.1


Severity

Recommended
0.0
low
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.54% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-MOIN-326611
  • published22 Feb 2011
  • disclosed22 Feb 2011

Introduced: 22 Feb 2011

CVE-2011-1058  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 moin to version 1.9.3-1ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream moin package and not the moin package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the reStructuredText (rst) parser in parser/text_rst.py in MoinMoin before 1.9.3, when docutils is installed or when "format rst" is set, allows remote attackers to inject arbitrary web script or HTML via a javascript: URL in the refuri attribute. NOTE: some of these details are obtained from third party information.

CVSS Base Scores

version 3.1