Improper Input Validation Affecting mongodb package, versions <1:2.0.4-1ubuntu2.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
44.54% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-MONGODB-382143
  • published1 Oct 2013
  • disclosed1 Oct 2013

Introduced: 1 Oct 2013

CVE-2013-1892  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 mongodb to version 1:2.0.4-1ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mongodb package and not the mongodb package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the nativeHelper function in SpiderMonkey, which allows remote authenticated users to cause a denial of service (invalid memory access and server crash) or execute arbitrary code via a crafted memory address in the first argument.

CVSS Base Scores

version 3.1