Resource Management Errors Affecting mono package, versions <2.10.8.1-1ubuntu2.3


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.69% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-MONO-301634
  • published13 Apr 2011
  • disclosed13 Apr 2011

Introduced: 13 Apr 2011

CVE-2011-0992  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 mono to version 2.10.8.1-1ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mono package and not the mono package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Use-after-free vulnerability in Mono, when Moonlight 2.x before 2.4.1 or 3.x before 3.99.3 is used, allows remote attackers to cause a denial of service (plugin crash) or obtain sensitive information via vectors related to member data in a resurrected MonoThread instance.

CVSS Base Scores

version 3.1