Cross-site Scripting (XSS) Affecting mono package, versions <2.10.8.1-1ubuntu2.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.91% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-MONO-301685
  • published12 Jul 2012
  • disclosed12 Jul 2012

Introduced: 12 Jul 2012

CVE-2012-3382  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 mono to version 2.10.8.1-1ubuntu2.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mono package and not the mono package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the ProcessRequest function in mcs/class/System.Web/System.Web/HttpForbiddenHandler.cs in Mono 2.10.8 and earlier allows remote attackers to inject arbitrary web script or HTML via a file with a crafted name and a forbidden extension, which is not properly handled in an error message.

CVSS Base Scores

version 3.1