Out-of-Bounds Affecting mupdf package, versions <0.9-2+deb7u3ubuntu0.12.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
14.79% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-MUPDF-382427
  • published3 Mar 2014
  • disclosed3 Mar 2014

Introduced: 3 Mar 2014

CVE-2014-2013  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 mupdf to version 0.9-2+deb7u3ubuntu0.12.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mupdf package and not the mupdf package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Stack-based buffer overflow in the xps_parse_color function in xps/xps-common.c in MuPDF 1.3 and earlier allows remote attackers to execute arbitrary code via a large number of entries in the ContextColor value of the Fill attribute in a Path element.

CVSS Base Scores

version 3.1