Access Restriction Bypass Affecting nbd package, versions <1:2.9.25-2ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.54% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-NBD-289483
  • published7 Dec 2013
  • disclosed7 Dec 2013

Introduced: 7 Dec 2013

CVE-2013-6410  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 nbd to version 1:2.9.25-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nbd package and not the nbd package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

nbd-server in Network Block Device (nbd) before 3.5 does not properly check IP addresses, which might allow remote attackers to bypass intended access restrictions via an IP address that has a partial match in the authfile configuration file.

CVSS Base Scores

version 3.1