Resource Management Errors Affecting nbd package, versions <1:2.9.25-2ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.72% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-NBD-289496
  • published29 May 2015
  • disclosed29 May 2015

Introduced: 29 May 2015

CVE-2013-7441  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 nbd to version 1:2.9.25-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nbd package and not the nbd package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The modern style negotiation in Network Block Device (nbd-server) 2.9.22 through 3.3 allows remote attackers to cause a denial of service (root process termination) by (1) closing the connection during negotiation or (2) specifying a name for a non-existent export.

CVSS Base Scores

version 3.1