CVE-2014-1545 Affecting nspr package, versions <4.9.5-0ubuntu0.12.04.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.33% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-NSPR-322059
  • published11 Jun 2014
  • disclosed11 Jun 2014

Introduced: 11 Jun 2014

CVE-2014-1545  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 nspr to version 4.9.5-0ubuntu0.12.04.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nspr package and not the nspr package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Mozilla Netscape Portable Runtime (NSPR) before 4.10.6 allows remote attackers to execute arbitrary code or cause a denial of service (out-of-bounds write) via vectors involving the sprintf and console functions.

CVSS Base Scores

version 3.1