Access Restriction Bypass Affecting nvidia-graphics-drivers package, versions <295.40-0ubuntu1.1


Severity

Recommended
0.0
high
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.39% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-NVIDIAGRAPHICSDRIVERS-385385
  • published19 Nov 2012
  • disclosed19 Nov 2012

Introduced: 19 Nov 2012

CVE-2012-4225  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 nvidia-graphics-drivers to version 295.40-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-graphics-drivers package and not the nvidia-graphics-drivers package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

NVIDIA UNIX graphics driver before 295.71 and before 304.32 allows local users to write to arbitrary physical memory locations and gain privileges by modifying the VGA window using /dev/nvidia0.

CVSS Base Scores

version 3.1