Directory Traversal Affecting pam package, versions <1.1.3-7ubuntu2.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.11% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PAM-322856
  • published10 Apr 2014
  • disclosed10 Apr 2014

Introduced: 10 Apr 2014

CVE-2014-2583  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 pam to version 1.1.3-7ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam package and not the pam package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

CVSS Base Scores

version 3.1