Out-of-Bounds Affecting pgbouncer package, versions <1.4.2-2ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.13% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PGBOUNCER-282435
  • published18 Nov 2012
  • disclosed18 Nov 2012

Introduced: 18 Nov 2012

CVE-2012-4575  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 pgbouncer to version 1.4.2-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pgbouncer package and not the pgbouncer package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The add_database function in objects.c in the pgbouncer pooler 1.5.2 for PostgreSQL allows remote attackers to cause a denial of service (daemon outage) via a long database name in a request.

CVSS Base Scores

version 3.1