Out-of-Bounds Affecting ppp package, versions <2.4.5-5ubuntu1.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.41% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PPP-337545
  • published24 Apr 2015
  • disclosed24 Apr 2015

Introduced: 24 Apr 2015

CVE-2015-3310  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 ppp to version 2.4.5-5ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ppp package and not the ppp package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Buffer overflow in the rc_mksid function in plugins/radius/util.c in Paul's PPP Package (ppp) 2.4.6 and earlier, when the PID for pppd is greater than 65535, allows remote attackers to cause a denial of service (crash) via a start accounting message to the RADIUS server.

CVSS Base Scores

version 3.1