Out-of-Bounds Affecting procmail package, versions <3.22-19ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
8.87% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PROCMAIL-288164
  • published8 Sept 2014
  • disclosed8 Sept 2014

Introduced: 8 Sep 2014

CVE-2014-3618  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 procmail to version 3.22-19ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream procmail package and not the procmail package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Heap-based buffer overflow in formisc.c in formail in procmail 3.22 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted email header, related to "unbalanced quotes."

CVSS Base Scores

version 3.1