OS Command Injection Affecting pygments package, versions <1.4+dfsg-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.72% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PYGMENTS-281985
  • published8 Jan 2016
  • disclosed8 Jan 2016

Introduced: 8 Jan 2016

CVE-2015-8557  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 pygments to version 1.4+dfsg-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pygments package and not the pygments package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.

CVSS Base Scores

version 3.1