Improper Input Validation Affecting pyopenssl package, versions <0.12-1ubuntu2.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.2% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PYOPENSSL-280435
  • published30 Sept 2013
  • disclosed30 Sept 2013

Introduced: 30 Sep 2013

CVE-2013-4314  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 pyopenssl to version 0.12-1ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pyopenssl package and not the pyopenssl package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The X509Extension in pyOpenSSL before 0.13.1 does not properly handle a '\0' character in a domain name in the Subject Alternative Name field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

CVSS Base Scores

version 3.1