Cryptographic Issues Affecting python-crypto package, versions <2.4.1-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.37% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PYTHONCRYPTO-343475
  • published17 Jun 2012
  • disclosed17 Jun 2012

Introduced: 17 Jun 2012

CVE-2012-2417  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 python-crypto to version 2.4.1-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-crypto package and not the python-crypto package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

PyCrypto before 2.6 does not produce appropriate prime numbers when using an ElGamal scheme to generate a key, which reduces the signature space or public key space and makes it easier for attackers to conduct brute force attacks to obtain the private key.

CVSS Base Scores

version 3.1