Improper Input Validation Affecting python-httplib2 package, versions <0.7.2-1ubuntu2.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.32% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-PYTHONHTTPLIB2-289523
  • published18 Jan 2014
  • disclosed18 Jan 2014

Introduced: 18 Jan 2014

CVE-2013-2037  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 python-httplib2 to version 0.7.2-1ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-httplib2 package and not the python-httplib2 package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

httplib2 0.7.2, 0.8, and earlier, after an initial connection is made, does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

CVSS Base Scores

version 3.1