Out-of-Bounds Affecting quagga package, versions <0.99.20.1-0ubuntu0.12.04.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.8% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-QUAGGA-319664
  • published5 Apr 2012
  • disclosed5 Apr 2012

Introduced: 5 Apr 2012

CVE-2012-0249  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 quagga to version 0.99.20.1-0ubuntu0.12.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Buffer overflow in the ospf_ls_upd_list_lsa function in ospf_packet.c in the OSPFv2 implementation in ospfd in Quagga before 0.99.20.1 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a Link State Update (aka LS Update) packet that is smaller than the length specified in its header.

CVSS Base Scores

version 3.1