Out-of-Bounds Affecting quagga package, versions <0.99.20.1-0ubuntu0.12.04.4


Severity

Recommended
0.0
low
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.08% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-QUAGGA-319697
  • published24 Oct 2013
  • disclosed24 Oct 2013

Introduced: 24 Oct 2013

CVE-2013-2236  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 quagga to version 0.99.20.1-0ubuntu0.12.04.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Stack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.

CVSS Base Scores

version 3.1