Out-of-Bounds Affecting quagga package, versions <0.99.20.1-0ubuntu0.12.04.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.45% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-QUAGGA-319730
  • published5 Apr 2012
  • disclosed5 Apr 2012

Introduced: 5 Apr 2012

CVE-2012-0255  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 quagga to version 0.99.20.1-0ubuntu0.12.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The BGP implementation in bgpd in Quagga before 0.99.20.1 does not properly use message buffers for OPEN messages, which allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a message associated with a malformed Four-octet AS Number Capability (aka AS4 capability).

CVSS Base Scores

version 3.1