Numeric Errors Affecting rpm package, versions <4.9.1.1-1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.23% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-RPM-415898
  • published4 Jun 2012
  • disclosed4 Jun 2012

Introduced: 4 Jun 2012

CVE-2012-0815  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 rpm to version 4.9.1.1-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm package and not the rpm package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The headerVerifyInfo function in lib/header.c in RPM before 4.9.1.3 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a negative value in a region offset of a package header, which is not properly handled in a numeric range comparison.

CVSS Base Scores

version 3.1