CVE-2014-3504 Affecting serf package, versions <1.0.0-2ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.15% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-SERF-282258
  • published19 Aug 2014
  • disclosed19 Aug 2014

Introduced: 19 Aug 2014

CVE-2014-3504  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 serf to version 1.0.0-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream serf package and not the serf package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The (1) serf_ssl_cert_issuer, (2) serf_ssl_cert_subject, and (3) serf_ssl_cert_certificate functions in Serf 0.2.0 through 1.3.x before 1.3.7 does not properly handle a NUL byte in a domain name in the subject's Common Name (CN) field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

CVSS Base Scores

version 3.1