Improper Input Validation Affecting software-properties package, versions <0.82.7.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.97% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-SOFTWAREPROPERTIES-288033
  • published10 Oct 2012
  • disclosed10 Oct 2012

Introduced: 10 Oct 2012

CVE-2012-5356  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 software-properties to version 0.82.7.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream software-properties package and not the software-properties package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The apt-add-repository tool in Ubuntu Software Properties 0.75.x before 0.75.10.3, 0.80.x before 0.80.9.2, 0.81.x before 0.81.13.5, 0.82.x before 0.82.7.3, and 0.92.x before 0.92.8 does not properly check PPA GPG keys imported from a keyserver, which allows remote attackers to install arbitrary package repository GPG keys via a man-in-the-middle (MITM) attack.

CVSS Base Scores

version 3.1