OS Command Injection The advisory has been revoked - it doesn't affect any version of package spamassassin  (opens in a new tab)


Threat Intelligence

EPSS
6.46% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-SPAMASSASSIN-546436
  • published30 Jan 2020
  • disclosed30 Jan 2020

Introduced: 30 Jan 2020

CVE-2020-1931  (opens in a new tab)
CWE-78  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:12.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spamassassin package and not the spamassassin package as distributed by Ubuntu.

A command execution issue was found in Apache SpamAssassin prior to 3.4.3. Carefully crafted nefarious Configuration (.cf) files can be configured to run system commands similar to CVE-2018-11805. This issue is less stealthy and attempts to exploit the issue will throw warnings. Thanks to Damian Lukowski at credativ for reporting the issue ethically. With this bug unpatched, exploits can be injected in a number of scenarios though doing so remotely is difficult. In addition to upgrading to SA 3.4.4, we again recommend that users should only use update channels or 3rd party .cf files from trusted places.