Improper Input Validation Affecting subversion package, versions <1.6.17dfsg-3ubuntu3.4


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
11.05% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-SUBVERSION-344405
  • published14 Feb 2014
  • disclosed14 Feb 2014

Introduced: 14 Feb 2014

CVE-2014-0032  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 subversion to version 1.6.17dfsg-3ubuntu3.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion package and not the subversion package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

The get_resource function in repos.c in the mod_dav_svn module in Apache Subversion before 1.7.15 and 1.8.x before 1.8.6, when SVNListParentPath is enabled, allows remote attackers to cause a denial of service (crash) via vectors related to the server root and request methods other than GET, as demonstrated by the "svn ls http://svn.example.com&#34; command.

References

CVSS Base Scores

version 3.1