Out-of-Bounds Affecting tidy package, versions <20091223cvs-1ubuntu2.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.63% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-TIDY-297964
  • published11 Aug 2015
  • disclosed11 Aug 2015

Introduced: 11 Aug 2015

CVE-2015-5522  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 tidy to version 20091223cvs-1ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tidy package and not the tidy package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Heap-based buffer overflow in the ParseValue function in lexer.c in tidy before 4.9.31 allows remote attackers to cause a denial of service (crash) via vectors involving a command character in an href.

CVSS Base Scores

version 3.1