In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.
Test your applicationsUpgrade Ubuntu:12.04 w3m to version 0.5.3-5ubuntu1.2 or higher.
Note: Versions mentioned in the description apply only to the upstream w3m package and not the w3m package as distributed by Ubuntu.
See How to fix? for Ubuntu:12.04 relevant fixed versions and status.
An issue was discovered in the Tatsuya Kinoshita w3m fork before 0.5.3-33. Infinite recursion vulnerability in w3m allows remote attackers to cause a denial of service via a crafted HTML page.