Improper Access Control Affecting xen package, versions <4.1.6.1-0ubuntu0.12.04.8


Severity

Recommended
0.0
high
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.08% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-XEN-365825
  • published14 Apr 2016
  • disclosed14 Apr 2016

Introduced: 14 Apr 2016

CVE-2015-8550  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 xen to version 4.1.6.1-0ubuntu0.12.04.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xen package and not the xen package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Xen, when used on a system providing PV backends, allows local guest OS administrators to cause a denial of service (host OS crash) or gain privileges by writing to memory shared between the frontend and backend, aka a double fetch vulnerability.