Integer Overflow or Wraparound Affecting xorg-server-lts-trusty package, versions <2:1.15.1-0ubuntu2~precise3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.3% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1204-XORGSERVERLTSTRUSTY-281951
  • published10 Dec 2014
  • disclosed10 Dec 2014

Introduced: 10 Dec 2014

CVE-2014-8094  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.04 xorg-server-lts-trusty to version 2:1.15.1-0ubuntu2~precise3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xorg-server-lts-trusty package and not the xorg-server-lts-trusty package as distributed by Ubuntu. See How to fix? for Ubuntu:12.04 relevant fixed versions and status.

Integer overflow in the ProcDRI2GetBuffers function in the DRI2 extension in X.Org Server (aka xserver and xorg-server) 1.7.0 through 1.16.x before 1.16.3 allows remote authenticated users to cause a denial of service (crash) or possibly execute arbitrary code via a crafted request, which triggers an out-of-bounds read or write.

CVSS Base Scores

version 3.1