Cryptographic Issues Affecting cinder package, versions <2012.2.4-0ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.88% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-CINDER-307848
  • published2 Feb 2014
  • disclosed2 Feb 2014

Introduced: 2 Feb 2014

CVE-2013-6491  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 cinder to version 2012.2.4-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cinder package and not the cinder package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

The python-qpid client (common/rpc/impl_qpid.py) in OpenStack Oslo before 2013.2 does not enforce SSL connections when qpid_protocol is set to ssl, which allows remote attackers to obtain sensitive information by sniffing the network.

CVSS Base Scores

version 3.1