Resource Management Errors Affecting firebird2.5 package, versions <2.5.2~svn+54698.ds4-1ubuntu0.12.10.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.84% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-FIREBIRD25-282400
  • published20 Nov 2012
  • disclosed20 Nov 2012

Introduced: 20 Nov 2012

CVE-2012-5529  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 firebird2.5 to version 2.5.2~svn+54698.ds4-1ubuntu0.12.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird2.5 package and not the firebird2.5 package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

TraceManager in Firebird 2.5.0 and 2.5.1, when trace is enabled, allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) by preparing an empty dynamic SQL query.

CVSS Base Scores

version 3.1