Credentials Management Affecting gnupg package, versions <1.4.11-3ubuntu4.4


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.45% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-GNUPG-340523
  • published20 Dec 2013
  • disclosed20 Dec 2013

Introduced: 20 Dec 2013

CVE-2013-4576  (opens in a new tab)
CWE-255  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 gnupg to version 1.4.11-3ubuntu4.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnupg package and not the gnupg package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

GnuPG 1.x before 1.4.16 generates RSA keys using sequences of introductions with certain patterns that introduce a side channel, which allows physically proximate attackers to extract RSA keys via a chosen-ciphertext attack and acoustic cryptanalysis during decryption. NOTE: applications are not typically expected to protect themselves from acoustic side-channel attacks, since this is arguably the responsibility of the physical device. Accordingly, issues of this type would not normally receive a CVE identifier. However, for this issue, the developer has specified a security policy in which GnuPG should offer side-channel resistance, and developer-specified security-policy violations are within the scope of CVE.

CVSS Base Scores

version 3.1