Information Exposure Affecting gnupg package, versions <1.4.11-3ubuntu4.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.53% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-GNUPG-340569
  • published19 Aug 2013
  • disclosed19 Aug 2013

Introduced: 19 Aug 2013

CVE-2013-4242  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 gnupg to version 1.4.11-3ubuntu4.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnupg package and not the gnupg package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

GnuPG before 1.4.14, and Libgcrypt before 1.5.3 as used in GnuPG 2.0.x and possibly other products, allows local users to obtain private RSA keys via a cache side-channel attack involving the L3 cache, aka Flush+Reload.

CVSS Base Scores

version 3.1