Link Following Affecting libimobiledevice package, versions <1.1.4-1ubuntu3.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.27% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-LIBIMOBILEDEVICE-317914
  • published19 Jan 2014
  • disclosed19 Jan 2014

Introduced: 19 Jan 2014

CVE-2013-2142  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 libimobiledevice to version 1.1.4-1ubuntu3.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libimobiledevice package and not the libimobiledevice package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

userpref.c in libimobiledevice 1.1.4, when $HOME and $XDG_CONFIG_HOME are not set, allows local users to overwrite arbitrary files via a symlink attack on (1) HostCertificate.pem, (2) HostPrivateKey.pem, (3) libimobiledevicerc, (4) RootCertificate.pem, or (5) RootPrivateKey.pem in /tmp/root/.config/libimobiledevice/.

CVSS Base Scores

version 3.1