Numeric Errors Affecting libxcb package, versions <1.8.1-1ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.45% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-LIBXCB-277008
  • published15 Jun 2013
  • disclosed15 Jun 2013

Introduced: 15 Jun 2013

CVE-2013-2064  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 libxcb to version 1.8.1-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxcb package and not the libxcb package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

Integer overflow in X.org libxcb 1.9 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the read_packet function.

CVSS Base Scores

version 3.1