Numeric Errors Affecting libxcursor package, versions <1:1.1.13-1ubuntu0.12.10.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.13% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-LIBXCURSOR-282525
  • published15 Jun 2013
  • disclosed15 Jun 2013

Introduced: 15 Jun 2013

CVE-2013-2003  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 libxcursor to version 1:1.1.13-1ubuntu0.12.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxcursor package and not the libxcursor package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

Integer overflow in X.org libXcursor 1.1.13 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the _XcursorFileHeaderCreate function.

CVSS Base Scores

version 3.1