Out-of-Bounds Affecting libxvmc package, versions <2:1.0.7-1ubuntu1.12.10.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.33% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-LIBXVMC-281626
  • published15 Jun 2013
  • disclosed15 Jun 2013

Introduced: 15 Jun 2013

CVE-2013-1999  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 libxvmc to version 2:1.0.7-1ubuntu1.12.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxvmc package and not the libxvmc package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

Buffer overflow in X.org libXvMC 1.0.7 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the XvMCGetDRInfo function.

CVSS Base Scores

version 3.1