CVE-2012-6081 Affecting moin package, versions <1.9.3-1ubuntu3.1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
35.35% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-MOIN-326449
  • published3 Jan 2013
  • disclosed3 Jan 2013

Introduced: 3 Jan 2013

CVE-2012-6081  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 moin to version 1.9.3-1ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream moin package and not the moin package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

Multiple unrestricted file upload vulnerabilities in the (1) twikidraw (action/twikidraw.py) and (2) anywikidraw (action/anywikidraw.py) actions in MoinMoin before 1.9.6 allow remote authenticated users with write permissions to execute arbitrary code by uploading a file with an executable extension, then accessing it via a direct request to the file in an unspecified directory, as exploited in the wild in July 2012.

CVSS Base Scores

version 3.1