Improper Authentication Affecting qpid-cpp package, versions <0.16-7ubuntu1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.39% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-QPIDCPP-356105
  • published27 Aug 2012
  • disclosed27 Aug 2012

Introduced: 27 Aug 2012

CVE-2012-3467  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 qpid-cpp to version 0.16-7ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qpid-cpp package and not the qpid-cpp package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

Apache QPID 0.14, 0.16, and earlier uses a NullAuthenticator mechanism to authenticate catch-up shadow connections to AMQP brokers, which allows remote attackers to bypass authentication.

CVSS Base Scores

version 3.1