Credentials Management Affecting rpm package, versions <4.10.0-4ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.25% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-RPM-415927
  • published18 Jan 2013
  • disclosed18 Jan 2013

Introduced: 18 Jan 2013

CVE-2012-6088  (opens in a new tab)
CWE-255  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 rpm to version 4.10.0-4ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm package and not the rpm package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

The rpmpkgRead function in lib/package.c in RPM 4.10.x before 4.10.2 does not return an error code in certain situations involving an "unparseable signature," which allows remote attackers to bypass RPM signature checks via a crafted package.

CVSS Base Scores

version 3.1