Resource Management Errors Affecting tiff package, versions <4.0.2-1ubuntu2.3


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.02% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-TIFF-406138
  • published10 Sept 2013
  • disclosed10 Sept 2013

Introduced: 10 Sep 2013

CVE-2013-4232  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 tiff to version 4.0.2-1ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tiff package and not the tiff package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

Use-after-free vulnerability in the t2p_readwrite_pdf_image function in tools/tiff2pdf.c in libtiff 4.0.3 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted TIFF image.

CVSS Base Scores

version 3.1