Improper Input Validation Affecting tomcat7 package, versions <7.0.30-0ubuntu1.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
16.21% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-TOMCAT7-364093
  • published26 Feb 2014
  • disclosed26 Feb 2014

Introduced: 26 Feb 2014

CVE-2013-4286  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 tomcat7 to version 7.0.30-0ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat7 package and not the tomcat7 package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

Apache Tomcat before 6.0.39, 7.x before 7.0.47, and 8.x before 8.0.0-RC3, when an HTTP connector or AJP connector is used, does not properly handle certain inconsistent HTTP request headers, which allows remote attackers to trigger incorrect identification of a request's length and conduct request-smuggling attacks via (1) multiple Content-Length headers or (2) a Content-Length header and a "Transfer-Encoding: chunked" header. NOTE: this vulnerability exists because of an incomplete fix for CVE-2005-2090.

References

CVSS Base Scores

version 3.1