Access Restriction Bypass Affecting usb-creator package, versions <0.2.40ubuntu2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.37% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1210-USBCREATOR-265852
  • published3 Oct 2013
  • disclosed3 Oct 2013

Introduced: 3 Oct 2013

CVE-2013-1063  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:12.10 usb-creator to version 0.2.40ubuntu2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream usb-creator package and not the usb-creator package as distributed by Ubuntu. See How to fix? for Ubuntu:12.10 relevant fixed versions and status.

usb-creator 0.2.47 before 0.2.47.1, 0.2.40 before 0.2.40ubuntu2, and 0.2.38 before 0.2.38.2 does not properly use D-Bus for communication with a polkit authority, which allows local users to bypass intended access restrictions by leveraging a PolkitUnixProcess PolkitSubject race condition via a (1) setuid process or (2) pkexec process, a related issue to CVE-2013-4288.

CVSS Base Scores

version 3.1