Improper Input Validation Affecting boost1.49 package, versions <1.49.0-3.2ubuntu1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.87% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1304-BOOST149-268464
  • published12 Mar 2013
  • disclosed12 Mar 2013

Introduced: 12 Mar 2013

CVE-2013-0252  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:13.04 boost1.49 to version 1.49.0-3.2ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream boost1.49 package and not the boost1.49 package as distributed by Ubuntu. See How to fix? for Ubuntu:13.04 relevant fixed versions and status.

boost::locale::utf::utf_traits in the Boost.Locale library in Boost 1.48 through 1.52 does not properly detect certain invalid UTF-8 sequences, which might allow remote attackers to bypass input validation protection mechanisms via crafted trailing bytes.

CVSS Base Scores

version 3.1